Temporarily unsupported parameters in the List Services API
Incident Report for PagerDuty
Postmortem

Summary

Between June 8th 18:37 UTC and June 9th 12:49 UTC, a change to the List Services API caused the query and time_zone parameters to be ignored. Customers were still able to make successful requests; however, as the query parameters were ignored, customers may have received an unexpected response. As the same API is utilized by the PagerDuty web page, customers using the "+ New Incident" button were unable to search for and select the correct service in the "Impacted Service" dropdown when attempting to create a new incident. The issue was resolved by restoring the previous functionality on June 9th 12:49 UTC.

What Happened

Due to a code change deployed on June 8th 18:37 UTC on our List Services API, the query and time_zone parameters were no longer being passed through to the service responsible for the List Services API. As a result, the query and time_zone parameters were ignored, but requests still appeared successful. Customers who utilized these parameters via the API or attempted to search for a specific Impacted Service via the UI would have received an unexpected list of services.

This was reported by customers on June 8th 22:57 UTC and a ticket was created for engineering to investigate. On June 9th 12:01 UTC, Support spun up an incident call in response to additional reports from customers. By June 9th 12:49 UTC, we identified the issue and deployed a fix.

What We Are Doing About This

Along with the fix that went out, we’ve added automated tests in order to prevent this exact issue from happening again. We will also conduct an investigation to prevent future changes from unexpectedly modifying our API contract going forward. We sincerely apologize for the impact these changes to our Services Index API had on you and your teams. For any additional questions contact our support team at support@pagerduty.com.

Posted Jun 17, 2022 - 18:40 UTC

Resolved
Between June 8th 18:37 UTC and June 9th 12:49 UTC, a change to the List Services API caused the query and time_zone parameters to be ignored. Customers were still able to make successful requests; however, as the query parameters were ignored, customers may have received an unexpected response. As the same API is utilized by the PagerDuty web page, customers using the "+ New Incident" button were unable to search for and select the correct service in the "Impacted Service" dropdown when attempting to create a new incident. The issue was resolved by restoring the previous functionality on June 9th 12:49 UTC.
Posted Jun 09, 2022 - 12:30 UTC