Inaccurate billing emails
Incident Report for PagerDuty
Resolved
A series of billing-related emails were sent out to customers from a non-PagerDuty email address. We have identified the cause of these billing email notifications and will be reaching out to affected customers. Our billing service is working as expected.
Posted Feb 05, 2021 - 16:33 UTC
Investigating
We are seeing a number of billing-related emails being sent to customers with inaccurate information regarding their accounts. We are actively investigating this issue.
Posted Feb 05, 2021 - 16:04 UTC