Delayed Incident Notifications
Incident Report for PagerDuty
Resolved
We have resolved an incident where PagerDuty customers in the US service region experienced issues with notification delivery. The incident is now resolved, and there is no ongoing impact to customers. Please reach out to support@pagerduty.com if you have any concerns.
Posted Nov 06, 2022 - 02:49 UTC
Monitoring
We are monitoring improvement in an incident with delayed incident notification. We have deployed a fix, and all delayed incident notifications have now been sent out.
Posted Nov 06, 2022 - 02:46 UTC
Investigating
We are investigating potential issues with delayed Incident Notifications in the US region within PagerDuty. On confirmation, we will update with further impact and severity within 15 minutes.
Posted Nov 06, 2022 - 02:35 UTC
This incident affected: Notification Delivery (Notification Delivery (US), SMS (US), Voice (US), Push (US), Email (US), Responder Requests (US), Status Updates (US)).