Zendesk integration issues
Incident Report for PagerDuty
Postmortem

Summary

On July, 30 2021, at approximately 17:00 UTC through 1:26 UTC, July 31, 2021, the Zendesk Service connection was not available across all customer accounts.

What Happened?

During manual operations intended to fix invalid data in the Zendesk Service database, account mappings were accidentally cleared from the database. Because of that, customers were not able to see their previously connected Zendesk accounts.

To fix the issue we restored the database using a snapshot. After that, the service returned to a stable state.

What Are We Doing About This?

Monitoring Improvements: We are adding additional monitoring to the Zendesk Service to further reduce the Mean-Time-To-Acknowledge (MTTA).

We’d like to apologize for the impact that this had on our customers. If you have any further questions, please reach out to support@pagerduty.com with these questions.

Posted Sep 14, 2021 - 08:01 UTC

Resolved
This incident has been resolved.
Posted Jul 31, 2021 - 01:23 UTC
Monitoring
This issue has now been resolved and connections between Zendesk and PagerDuty should be back to normal. If you encounter any further issues please reach out to PagerDuty support.
Posted Jul 31, 2021 - 01:07 UTC
Update
We are continuing to work on correcting the connections between PagerDuty and Zendesk.
Posted Jul 31, 2021 - 00:54 UTC
Identified
We have identified the issue and are working to correct the connections between PagerDuty and Zendesk.
Posted Jul 31, 2021 - 00:25 UTC
Investigating
PagerDuty is currently investigating an issue with the Zendesk integration, including issues with extensions to Zendesk and connectivity between Zendesk tickets and PagerDuty incidents. We believe that issues are limited to the v2 and v3 version of the integration.
Posted Jul 30, 2021 - 23:56 UTC
This incident affected: Integrations (Zendesk (US)).