Delayed Log Entries
Incident Report for PagerDuty
Postmortem

Summary

On September 17, from 4:19 UTC to 5:45 UTC, PagerDuty experienced latencies in our log entry service.

What Happened

During this incident, notifications were unaffected, but there were delays in delivering incident details and incident timelines due to networking errors.

What Are We Doing About This

To mitigate the occurrence of this issue going forward, we are adding measures to increase resiliency to host networking for the impacted component.

We would like to express our sincere regret for the delays in the incident detail fields that resulted from the service latency issues. For any questions, comments, or concerns, please contact us at support@pagerduty.com

Posted 30 days ago. Sep 23, 2019 - 22:32 UTC

Resolved
The issue has been resolved and all processes are working as expected.
Posted about 1 month ago. Sep 17, 2019 - 06:02 UTC
Investigating
We have identified internal latencies which are currently causing a delay in log entries. This will affect the timeline for incident details, the event body details of an incident, and some email details will be missing. Our engineers are actively working on resolving this issue.
Posted about 1 month ago. Sep 17, 2019 - 05:03 UTC